Monday, December 23, 2013

VLAN or virtual local area network is one way to classify Group segment LANs with different IP address, but the device is still in the network. If we have a cisco router with 2 interfaces, but we want to give the allocation of the different segments ip address for each department office, then we need a device under router that supports VLAN functions, such as cisco managable switch. Here is an example of a VLAN to the group bod, manager, accounting, purchasing, hrd, it and the employees. Simulations using a VLAN-making device cisco router 1841, Cisco 2950-24 switches, hubs, and end devices (pc).

To segment the IP address allocation is as follows :

  • bod with ip address 192.168.0.0/27 and interface fa 0/1
  • manager with ip address 192.168.1.0/27 and interface fa 0/2
  • accounting with ip address 192.168.2.0/27 and interface fa 0/3
  • purchasing with ip address 192.168.3.0/27 and interface fa 0/4
  • hrd with ip address 192.168.4.0/27 and interface fa 0/5
  • it staff with ip address 192.168.5.0/27 and interface fa 0/6
  • employees with ip address 192.168.6.0/24 and interface fa 0/7 
Segmentation based on a VLAN group, the switch cisco manageable (2950-24) can be setup as follows :
Switch>enable
Switch#vlan database
Switch(vlan)# vlan 100 name bod
Switch(vlan)# vlan 110 name manager
Switch(vlan)# vlan 120 name accounting
Switch(vlan)# vlan 130 name purchasing
Switch(vlan)# vlan 140 name hrd
Switch(vlan)# vlan 150 name it
Switch(vlan)# vlan 160 name karyawan
Switch(vlan)# exit
Switch#config t
Switch(config)#int fa 0/1
Switch(config-if)#switchport access vlan 100
Switch(config-if)#exit
Switch(config)#int fa 0/2
Switch(config-if)#switchport access vlan 110
Switch(config-if)#exit
Switch(config)#int fa 0/3
Switch(config-if)#switchport access vlan 120
Switch(config-if)#exit
Switch(config)#int fa 0/4
Switch(config-if)#switchport access vlan 130
Switch(config-if)#exit
Switch(config)#int fa 0/5
Switch(config-if)#switchport access vlan 140
Switch(config-if)#exit
Switch(config)#int fa 0/6
Switch(config-if)#switchport access vlan 150
Switch(config-if)#exit
Switch(config)#int fa 0/7
Switch(config-if)#switchport access vlan 160
Switch(config-if)#exit
If the VLAN database is OK, the next step we have to set 2950-24 trunk on the switch port connected to the Cisco router 1841 and in this setting we are using port 24 :
Switch#config t
Switch(config)#int fa 0/24
Switch(config-if)#switchport mode trunk
With the above steps, it means that the VLAN settings on the Switch 2950-24 has been completed and as a follow up of the VLAN-making we need to create a sub interface on cisco router 1841, which is on the sub-interface we have allocated to segment the IP address of a VLAN that has formed.
Router>enable
Router#conf t
Router(config)#int fa 0/0.100
Router(config-subif)#encapsulation dot1Q 100
Router(config-subif)#ip address 192.168.0.1 255.255.255.224
Router(config-subif)#exit
Router(config)#int fa 0/0.110
Router(config-subif)#encapsulation dot1Q 110
Router(config-subif)#ip address 192.168.1.1 255.255.255.224
Router(config-subif)#exit
Router(config)#int fa 0/0.120
Router(config-subif)#encapsulation dot1Q 120
Router(config-subif)#ip address 192.168.2.1 255.255.255.224
Router(config-subif)#exit
Router(config)#int fa 0/0.130
Router(config-subif)#encapsulation dot1Q 130
Router(config-subif)#ip address 192.168.3.1 255.255.255.224
Router(config-subif)#exit
Router(config)#int fa 0/0.140
Router(config-subif)#encapsulation dot1Q 140
Router(config-subif)#ip address 192.168.4.1 255.255.255.224
Router(config-subif)#exit
Router(config)#int fa 0/0.150
Router(config-subif)#encapsulation dot1Q 150
Router(config-subif)#ip address 192.168.5.1 255.255.255.224
Router(config-subif)#exit
Router(config)#int fa 0/0.160
Router(config-subif)#encapsulation dot1Q 160
Router(config-subif)#ip address 192.168.6.1 255.255.255.224
Router(config-subif)#exit
And do not forget to turn on (no shutdown) fast ethernet port 0/0 on a Cisco 1841 router and store it in memory router configuration with the following command :
Router#conf t
Router(config)#int fa 0/0
Router(config)# no shutdown
Router(config)#exit
Router# write memory
The application of this concept is suitable for VLAN segmentation ip address needs in a large company, because the concept we can map the VLAN segmentation in accordance with the ip address in the corporate department.
Thank You For Reading This Article
Title: Setting VLAN With Packet Tracer Simulation
Written by achmad saifudin
Give your comments and suggestions on this article. Greetings Bloggers, Thank You

0 comments:

Post a Comment